activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Gomes (JIRA)" <jira+amq...@apache.org>
Subject [jira] Resolved: (AMQNET-140) Incorrect parsing of failover URI
Date Wed, 11 Feb 2009 17:37:59 GMT

     [ https://issues.apache.org/activemq/browse/AMQNET-140?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jim Gomes resolved AMQNET-140.
------------------------------

    Resolution: Fixed

Fixed was applied when the patch for [AMQNET-135] was applied.  That patch had both fixes
in it.

> Incorrect parsing of failover URI
> ---------------------------------
>
>                 Key: AMQNET-140
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-140
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ Client
>    Affects Versions: 1.1
>            Reporter: Mark Keenan
>            Assignee: Jim Gomes
>             Fix For: 1.1
>
>         Attachments: AMQNET-140-741308.diff
>
>
> On the subject of uri syntax, I tried the following:
> "activemq:failover:(tcp://localhost:61616,tcp://localhost:61626,tcp://localhost:61636)"
> And it did not work.  I stepped into the code and I believe the splitComponents method
in the URISupport.cs class has a bug.  The returned value from that method, a String[] contains:
> components[0] == tcp://localhost:61616
> components[1] == tcp://localhost:61626,tcp://localhost:61636
> components[2] == tcp://localhost:61636
> This fails downstream because the port number cannot be parsed. 
> See details at: http://www.nabble.com/Re%3A--Apache.NMS.ActiveMQ-using-FailoverTransport-p21833315.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message