activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Ellis (JIRA)" <jira+amq...@apache.org>
Subject [jira] Updated: (AMQNET-146) Unit tests do not emit any tracing when compiled using nant
Date Wed, 25 Feb 2009 18:16:00 GMT

     [ https://issues.apache.org/activemq/browse/AMQNET-146?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Ellis updated AMQNET-146:
--------------------------------

    Attachment: EnableTracing.patch

I have attached a patch to enable tracing, but rather than change the nant configuration,
I have added the TRACE symbol to the NmsTrace class.  This will guarantee that the Trace statements
in the trace class always work regardless of the compilation arguments, and also means the
change won't effect the release build.

> Unit tests do not emit any tracing when compiled using nant
> -----------------------------------------------------------
>
>                 Key: AMQNET-146
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-146
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>    Affects Versions: 1.2
>         Environment: Building using NANT
>            Reporter: Daniel Ellis
>            Assignee: Jim Gomes
>            Priority: Trivial
>         Attachments: EnableTracing.patch
>
>
> When building using nant and testing with nunit.  No trace output is available.  This
is because the nant build script is not defining the TRACE symbol.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message