activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Building
Date Mon, 02 Feb 2009 22:33:29 GMT
That's rather odd, I've not had any issues with VS2005 or VS2008 like
that.  Are you able to run the example code using the DebugDLL or
ReleaseDLL configurations?

Regards
Tim.

On Mon, 2009-02-02 at 09:52 -0800, dj9 wrote:
> Hi Tim,
> 
> thanks for the response.
> 
> No I don't think that's what it is, I've never had any other version of ARP
> installed on my PC.
> 
> Regards
> Derek
> 
> 
> 
> Timothy Bish wrote:
> > 
> > On Mon, 2009-02-02 at 07:17 -0800, dj9 wrote:
> >> Hi there,
> >> 
> >> I have just started looking at using ActiveMQ and it's associated clients
> >> but am having some trouble with CMS on windows which hopefully somebody
> >> can
> >> shed some light on for me.
> >> 
> >> I want to use ActiveMQ and CMS to allow Windows (MFC) applications to
> >> talk
> >> (simple text) to each other and to other Linux applications (will be
> >> using
> >> Perl/Ruby client for Linux side).  From the examples available I can see
> >> that this is done easily within Ruby and Perl using Stomp and I have see
> >> Visual Studio (v2005) is supported for CMS.  I want to create a class
> >> using
> >> CMS which the Windows MFC applications can use to talk to each other and
> >> to
> >> the Linux applications via ActiveMQ.  I have downloaded the the latest
> >> version of ActiveMQ-CPP (v2.2.3) and have built the projects
> >> (vs2005-activemq, vs2005-activemq-example,
> >> vs2005-activemq-integration-tests, vs2005-activemq-unittests) within the
> >> supplied source using MS Visual Studio 2005.  I had to change the project
> >> setup slightly to be able to find all the referenced library directories
> >> and
> >> dlls where I'd installed the required tools, but aside from that didn't
> >> have
> >> to change much in the project.  Below is a list of the tools and their
> >> versions I'm using in my setup:
> >> ActiveMQ-CPP (v2.2.3)
> >> apr (v1.3.3)
> >> apr-iconv (v1.2.1)
> >> apr-util (v1.3.4)
> >> cppunit (v1.12.1)
> >> 
> >> My issue is that I cannot run the example projects either in debug or
> >> release mode, as I get the following Windows error "The procedure entry
> >> point _apr_pool_create_unmanaged_ex@12 could not be located in the
> >> dynamic
> >> link library libapr-1.dll".  However this does seem to be available and
> >> exists within the libapr-1.dll so I am confused as to what the issue is,
> >> can
> >> anybody see what I've done wrong?
> >> 
> >> Is what I am trying to achieve reasonable?  Should I be trying to solve
> >> my
> >> problem in another way?
> > 
> > Your setup seems reasonable and looks to mirror the versions that I use
> > on my windows install so I'm not sure why its not able to find that
> > method.  The first thing that comes to mind is that the loader is
> > finding an older version of APR's dll, you don't have any others laying
> > around that could be picked up on the system path do you?  
> > 
> > 
> > 
> >> 
> >> Many thanks in advance for your help.
> >> Kind regards
> >> Derek
> >> 
> >> 
> > -- 
> > Tim Bish
> > http://fusesource.com
> > http://timbish.blogspot.com/
> > 
> > 
> > 
> > 
> > 
> 
-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message