activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dejan Bosanac" <de...@nighttale.net>
Subject Re: Unable to setup : Default Persistence in ActiveMQ
Date Thu, 25 Dec 2008 08:48:16 GMT
I just tried your configuration and everything works fine. Start a broker,
send a message, close the broker, start it again and then consume the
message.


Cheers
--
Dejan Bosanac

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Wed, Dec 24, 2008 at 3:26 PM, ABHATNAGAR <bhatnagarankit@hotmail.com>wrote:

>
> This is how my activemq.xml looks like:
> =========================================================
> <!--
>    Licensed to the Apache Software Foundation (ASF) under one or more
>    contributor license agreements.  See the NOTICE file distributed with
>    this work for additional information regarding copyright ownership.
>    The ASF licenses this file to You under the Apache License, Version 2.0
>    (the "License"); you may not use this file except in compliance with
>    the License.  You may obtain a copy of the License at
>
>    http://www.apache.org/licenses/LICENSE-2.0
>
>    Unless required by applicable law or agreed to in writing, software
>    distributed under the License is distributed on an "AS IS" BASIS,
>    WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
>    See the License for the specific language governing permissions and
>    limitations under the License.
> -->
>        <!-- START SNIPPET: xbean -->
> <beans>
>
>
>  <broker brokerName="broker" useJmx="true" persistent="true"
> xmlns="http://activemq.apache.org/schema/core">
>
>    <!-- In ActiveMQ 4, you can setup destination policies -->
>    <destinationPolicy>
>      <policyMap>
>        <policyEntries>
>
>          <policyEntry topic="FOO.>">
>            <dispatchPolicy>
>              <strictOrderDispatchPolicy/>
>            </dispatchPolicy>
>            <subscriptionRecoveryPolicy>
>              <lastImageSubscriptionRecoveryPolicy/>
>            </subscriptionRecoveryPolicy>
>          </policyEntry>
>
>        </policyEntries>
>      </policyMap>
>    </destinationPolicy>
>
>
>
>    <transportConnectors>
>      <transportConnector name="openwire" uri="tcp://localhost:61616"
> discoveryUri="multicast://default"/>
>      <transportConnector name="stomp" uri="stomp://localhost:61613"/>
>      <transportConnector name="xmpp" uri="xmpp://localhost:61222"/>
>    </transportConnectors>
>
>  <persistenceAdapter>
>    <amqPersistenceAdapter directory="activemq-data" maxFileLength="32mb"/>
>    </persistenceAdapter>
>
>    <networkConnectors>
>      <!-- by default just auto discover the other brokers -->
>      <networkConnector name="defaultNetwork" uri="multicast://default"/>
>      <!--
>      <networkConnector name="host1 and host2"
> uri="static://(tcp://host1:61616,tcp://host2:61616)" failover="true"/>
>      -->
>    </networkConnectors>
>
>  </broker>
>
>  <!-- lets create a command agent to respond to admin commands over JMS or
> XMPP on the ActiveMQ.Agent topic -->
>  <commandAgent xmlns="http://activemq.apache.org/schema/core"/>
>
> </beans>
>
>
> I am using ActiveMQ 5.2.
>
> My use case is I need to persist the message by using the default
> PERSISTENCE.
> Also I have the DELIVERY MODE AS PERSISTENT
>
>
> Ankit
> --
> View this message in context:
> http://www.nabble.com/Unable-to-setup-%3A--Default-Persistence-in-ActiveMQ-tp21139023p21156858.html
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message