activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From saurabh85 <saurabh_sharm...@infosys.com>
Subject Re: repeated closing of socket in activeMQ, connection reset
Date Fri, 19 Dec 2008 04:56:59 GMT

Hi,
    I am giving the logs that I got.
     First of all, there is a wrapper for active MQ, and the log file for
activeMq shows like this:
         ERROR  | wrapper  | 2008/12/18 01:14:34 | JVM appears hung: Timed
out waiting for signal from JVM.

ERROR  | wrapper  | 2008/12/18 01:14:34 | JVM did not exit on request,
terminated

DEBUG  | wrapperp | 2008/12/18 01:14:36 | server listening on port 32001.

DEBUG  | wrapper  | 2008/12/18 01:14:36 | Waiting 5 seconds before launching
another JVM.

DEBUG  | wrapper  | 2008/12/18 01:14:40 | Signal trapped.  Details:

DEBUG  | wrapper  | 2008/12/18 01:14:40 |   signal number=17 (SIGCHLD),
source="unknown"

DEBUG  | wrapper  | 2008/12/18 01:14:40 | Received SIGCHLD, checking JVM
process status.

STATUS | wrapper  | 2008/12/18 01:14:40 | JVM exited in response to signal
SIGKILL (9).

DEBUG  | wrapper  | 2008/12/18 01:14:40 | JVM process exited with a code of
1, however the wrapper exit code was already 1.

ERROR  | wrapper  | 2008/12/18 01:14:40 | Unable to start a JVM

STATUS | wrapper  | 2008/12/18 01:14:41 | <-- Wrapper Stopped

In fstomp log file, we have the following messages:
1. Error processing frame
2. These functions are called one by one:
    a. handle_the_frame()
    b. process_the_frame()
    c. recieve_raw()
When it comes to receive_raw(), it raises an exception:
error: (111, 'Connection refused')
unable to send due to "<class 'socket.error'>: (32, 'Broken pipe')"

Theres another log file which manages everything:
unable to send "SEND

action:spc_query

mtype:request

destination:/topic/REQUEST

from:some-system-name

to:*:*

I am getting this error time and again which leads to shutdown of activeMQ
each now and then. Please help this out
  

Gary Tully wrote:
> 
> What information do you get from the logging?
> Any chance that is in the default inactivity timeout of 30 seconds
> which is kicking in?
> 
> 2008/12/18 saurabh85 <saurabh_sharma19@infosys.com>:
>>
>> There is some problem due to which the connection is getting closed
>> everytime.
>> Almost everyday, the connection gets reset. I am using active MQ versuion
>> 5.x
>>
>> Can any one tell me the possible reason ?? Is this some problem of
>> activeMQ
>> ?
>> --
>> View this message in context:
>> http://www.nabble.com/repeated-closing-of-socket-in-activeMQ%2C-connection-reset-tp21072892p21072892.html
>> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>>
>>
> 
> 
> 
> -- 
> http://blog.garytully.com
> 
> Open Source SOA
> http://FUSESource.com
> 
> 

-- 
View this message in context: http://www.nabble.com/repeated-closing-of-socket-in-activeMQ%2C-connection-reset-tp21072892p21085843.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message