activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Ubuntu 8.10 CMS ./configure missing APR
Date Wed, 10 Dec 2008 20:00:59 GMT
On Wed, 2008-12-10 at 11:42 -0800, twright123 wrote:
> First of all, I thank you for you quick response.
> 
> I thought of that, and you are right.  The apt-get version is really old.  I
> downloaded the source for apr-1.3.3 and apr-util-1.3.4.  I built apr, and
> that worked.  When I used --with-apr and the freshly build libraries, the
> ./configure found it.  
> 
> However, there is no build documentation for the apr-util.  I have trying to
> build that, but so far I have been unsuccessful.  

APR-Util is built pretty much the same way as APR except that you always
have to tell it where APR is, I've always had success building it by
running ./configure --with-apr=/usr which implies I've already installed
the fresh build of APR in /usr, replace that with where you have 1.3
installed.

> It might be a good idea to add apr-1.3 or higher and apr-util-1.3 or higher
> to the list of required libraries in the cms build instructions.

I think there is a note in the README but I could be wrong about that, 
I know its mentioned on the release page.  Documentation is an ongoing battle.


-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message