activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Gomes (JIRA)" <jira+amq...@apache.org>
Subject [jira] Updated: (AMQNET-122) Recent OpenWireFormat changes cause initial startup delays
Date Tue, 11 Nov 2008 00:44:05 GMT

     [ https://issues.apache.org/activemq/browse/AMQNET-122?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jim Gomes updated AMQNET-122:
-----------------------------

           Regression: [Regression]
        Fix Version/s: 1.1
    Affects Version/s: 1.1

> Recent OpenWireFormat changes cause initial startup delays
> ----------------------------------------------------------
>
>                 Key: AMQNET-122
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-122
>             Project: ActiveMQ .Net
>          Issue Type: Bug
>          Components: ActiveMQ Client
>    Affects Versions: 1.1
>         Environment: Windows XP, ActiveMQ 5.2.0 RC2+, latest Apache.NMS and Apache.NMS.ActiveMQ
>            Reporter: Allan Schrum
>            Assignee: Jim Gomes
>             Fix For: 1.1
>
>
> The recent changes to Apache.NMS.ActiveMQ's file OpenWire/OpenWireFormat.cs create massive
delays on my system. If I revert that file back to the version 693666 (09-Sep-2008) then all
my code starts working without delays. It seems that the action of writing to the bus (using
Topics in my case) is delayed 120 seconds or so. Each write seems to be delayed 15 seconds.
Since startup involves several writes the initialize the wire format, I suspect that a timeout
variable is set to 0 (zero) which does not allow a thread-swap to take place. I suspect that
the timeout should be set to 1 ms so that a context switch will take place.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message