activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Martens (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (AMQCPP-200) activemq-cpp-2.2.1 test fails for decaf::io::ByteArrayInputStreamTest::testConstructor (segmentation fault)
Date Mon, 06 Oct 2008 08:29:52 GMT

    [ https://issues.apache.org/activemq/browse/AMQCPP-200?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=46187#action_46187
] 

alex.martens edited comment on AMQCPP-200 at 10/6/08 1:29 AM:
-------------------------------------------------------------------

Back there.

I've done a deep clean up this morning and reinstalled apr and apr-util 1.2.8 directly from
Apache's rpms (rpm for apr, src.rpm for apr-util since the rpm holds a dependence for libpq
3, which I don't have - using libpq 4 instead; anyway, I don't think this is related to our
issue).

The unit test still fails for decaf::io::ByteArrayInputStreamTest::testConstructor.

I've also repeated the whole process on a fresh installed machine (RHEL 5.2 as well), and
I'm getting the same result.

Can somebody please confirm the segmentation fault?
Was anyone able to reproduce the crash?

Let me know if you need more information.

Thanks!

      was (Author: alex.martens):
    Back there.

I've done a deep clean up this morning and reinstalled apr and apr-util 1.2.8 directly from
Apache's rpms (rpm for apr, src.rpm for apr-util since the rpm holds a dependence for libpq
3, which I don't have - using libpq 4 instead; anyway, I don't thing this is related to our
issue).

The unit test still fails for decaf::io::ByteArrayInputStreamTest::testConstructor.

I've also repeated the whole process on a fresh installed machine (RHEL 5.2 as well), and
I'm getting the same result.

Can somebody please confirm the segmentation fault?
Was anyone able to reproduce the crash?

Let me know if you need more information.

Thanks!
  
> activemq-cpp-2.2.1 test fails for decaf::io::ByteArrayInputStreamTest::testConstructor
(segmentation fault)
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: AMQCPP-200
>                 URL: https://issues.apache.org/activemq/browse/AMQCPP-200
>             Project: ActiveMQ C++ Client
>          Issue Type: Bug
>          Components: Decaf
>    Affects Versions: 2.2.1
>         Environment: RHEL 5.2 (2.6.18-92.el5), apr-1.3.3, apr-util-1.3.4, cppunit-1.12.1,
gcc version 4.1.2 20071124 (Red Hat 4.1.2-42), Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
>            Reporter: Alexander Martens
>            Assignee: Timothy Bish
>         Attachments: testConstructor-O0.log.gz, testConstructor.log.gz, testString-O0.log.gz
>
>
> This unit test seems to fail.
> I send you attached a gdb postmortem log (bt, bt full, info threads). 
> Thanks!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message