activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Gomes (JIRA)" <jira+amq...@apache.org>
Subject [jira] Commented: (AMQNET-119) Remove support for .NET 1.1 in the ActiveMQ provider
Date Wed, 29 Oct 2008 16:23:53 GMT

    [ https://issues.apache.org/activemq/browse/AMQNET-119?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=46883#action_46883
] 

Jim Gomes commented on AMQNET-119:
----------------------------------

The AtomicReference.cs file that you contributed is checked in to the Apache.NMS project.
 Currently, that project is still targeting the .NET 1.1 runtime.  This particular JIRA was
only meant to address the ActiveMQ provider (Apache.NMS.ActiveMQ).  Since the Apache.NMS project
is the generic interface project, it would probably be a good idea to allow it to continue
targeting the .NET 1.1 runtime so that other provider implementors (MSMQ, TIBCO, etc.) can
still target the .NET 1.1 runtime if they choose to.  As for the ActiveMQ client provider
implementation, I don't think it is necessary to continue support for .NET 1.1.  Each provider
implementation should make its own decision as to which runtimes it  will support.

> Remove support for .NET 1.1 in the ActiveMQ provider
> ----------------------------------------------------
>
>                 Key: AMQNET-119
>                 URL: https://issues.apache.org/activemq/browse/AMQNET-119
>             Project: ActiveMQ .Net
>          Issue Type: Task
>          Components: ActiveMQ Client
>    Affects Versions: 1.1
>         Environment: .NET 2.0
>            Reporter: Jim Gomes
>            Assignee: Jim Gomes
>             Fix For: 1.1
>
>   Original Estimate: 2 hours
>  Remaining Estimate: 2 hours
>
> The .NET 1.1 environment is nearing obsolescence, and coding for this environment is
becoming increasing difficult, error prone, and complex.  The Apache.NMS.ActiveMQ 1.0.0 version
will continue support for .NET 1.1, but the 1.1.0 and newer versions will drop support for
that runtime environment.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message