activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Tully (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AMQ-1877) Invalid Topic Statistics
Date Mon, 08 Sep 2008 14:55:54 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-1877?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gary Tully updated AMQ-1877:
----------------------------

    Fix Version/s: 5.3.0
                       (was: 5.2.0)

> Invalid Topic Statistics
> ------------------------
>
>                 Key: AMQ-1877
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1877
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.0.0
>         Environment: Fuse Message Broker 5.0.0.14-fuse
>            Reporter: Trevor Pounds
>             Fix For: 5.3.0
>
>
> I'm not sure if this affects 5.0.0 directly but I imagine it does since I'm seeing this
in the 5.0.0.14-fuse release.
> When I have a single topic subscriber and publisher on a freshly started AMQ broker and
I send one message I see the following invalid statistics.
> {noformat}
> DequeueCount = 1
> DispatchCount = 1
> EnqueueCount = 1
> QueueSize = 1
> {noformat}
> What I expect to see is:
> {noformat}
> DequeueCount = 1
> DispatchCount = 1
> EnqueueCount = 1
> QueueSize = 0
> {noformat}
> I also noticed with one publisher and no subscribers and I send one message I see the
following:
> {noformat}
> DequeueCount = 0
> DispatchCount = 0
> EnqueueCount = 1
> QueueSize = 1
> {noformat}
> What I expect to see is:
> {noformat}
> DequeueCount = 0
> DispatchCount = 0
> EnqueueCount = 1
> QueueSize = 0
> {noformat}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message