activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Katz (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-1934) Message delivery blocks after broker failover
Date Thu, 11 Sep 2008 17:24:52 GMT
Message delivery blocks after broker failover
---------------------------------------------

                 Key: AMQ-1934
                 URL: https://issues.apache.org/activemq/browse/AMQ-1934
             Project: ActiveMQ
          Issue Type: Bug
    Affects Versions: 5.1.0
         Environment: Windows XP, ActiveMQ 5.1.0, Spring 2.5
            Reporter: Vadim Katz
         Attachments: activemq-failover-test.zip

Start two brokers with shared FS. One is locked out because journal is locked by the master
as it should be. Then run attached junit test case. The test does the following:
1. Sends and receives a message while both master and slave brokers are up.
2. Requests manual shutdown of master broker and expects slave to become master within 30
sec
3. Sends another message which is never received

You can observe via admin console that the message sent after broker failover is delivered
to the queue; however it is not delivered to a waiting listener. Also, you can observe the
logged invocations of TranportListener. Notice, how onCommand() calls are no longer continuously
made after failover (except for the first two).

Eclipse/Maven based test project is attached.

Please see "sends/receives block during failover" discussion for more information. thanks,
vadim

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message