activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wouter de vaal (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-1857) running activemq using maven causes NoClassDefFoundError: org/springframework/core/io/FileSystemResource
Date Thu, 14 Aug 2008 07:39:52 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-1857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=44955#action_44955
] 

Wouter de vaal commented on AMQ-1857:
-------------------------------------

That helps (imho this still needs fixing), but now I get namespace errors like:
Embedded error: Unrecognized xbean namespace mapping: http://mortbay.com/schemas/jetty/1.0
Adding jetty dependency did not help in this case...

> running activemq using maven causes NoClassDefFoundError: org/springframework/core/io/FileSystemResource
> --------------------------------------------------------------------------------------------------------
>
>                 Key: AMQ-1857
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1857
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 5.1.0
>         Environment: maven 2.0.9, java 1.6
>            Reporter: Wouter de vaal
>
> I tried to follow these instructions:
> http://activemq.apache.org/maven2-activemq-broker-plugin.html
> Create pom with plugin definition:
> 	<build>
> 		<plugins>
> 			<plugin>
> 				<groupId>org.apache.activemq.tooling</groupId>
> 				<artifactId>maven-activemq-plugin</artifactId>
> 				<version>5.1.0</version>
> 				<configuration>
> 					<configUri>
> 						xbean:file:activemq.xml
> 					</configUri>
> 					<fork>false</fork>
> 					<systemProperties>
> 						<property>
> 							<name>
> 								org.apache.activemq.default.directory.prefix
> 							</name>
> 							<value>./target/</value>
> 						</property>
> 					</systemProperties>
> 				</configuration>
> 			</plugin>
> 		</plugins>
> 	</build>
> And when I call mvn activemq:run
> I get:
> [INFO] Scanning for projects...
> [INFO] Searching repository for plugin with prefix: 'activemq'.
> [INFO] ------------------------------------------------------------------------
> [INFO] Building Memolio main project
> [INFO]    task-segment: [activemq:run]
> [INFO] ------------------------------------------------------------------------
> [INFO] [activemq:run]
> [INFO] Loading broker configUri: xbean:file:activemq.xml
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to start ActiveMQ Broker
> Embedded error: Could not load xbean factory:java.lang.NoClassDefFoundError: org/springframework/core/io/FileSystemResource
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2 seconds
> [INFO] Finished at: Thu Jul 17 15:40:50 CEST 2008
> [INFO] Final Memory: 5M/82M
> [INFO] ------------------------------------------------------------------------

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message