activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From EricMeena <mauvv...@yahoo.fr>
Subject Bridge Authentication problem - ActiveMQ_5.1
Date Tue, 01 Jul 2008 20:30:39 GMT

Hi,

I am trying to set up a bridge between two brokers with ssl and
authentication configured. By following the examples from 
http://activemq.apache.org/jms-to-jms-bridge.html , without ssl and
authentication enabled, I  successfully get my bridge connected to the
remote broker. 
But I am getting the following error while the bridge tries to connect to a
secured broker: 

WARN  TransportConnection            - Failed to add Connection
java.lang.SecurityException: User name or password is invalid.
        at
org.apache.activemq.security.JaasAuthenticationBroker.addConnection(JaasAuthenticationBroker.java:83)
        at
org.apache.activemq.broker.BrokerFilter.addConnection(BrokerFilter.java:81)
        at
org.apache.activemq.broker.MutableBrokerFilter.addConnection(MutableBrokerFilter.java:88)
...................................

The following is my configuration:

<broker
..................
		<jmsBridgeConnectors>
			<jmsQueueConnector
				outboundQueueConnectionFactory="#remoteFactory">
				<outboundQueueBridges>
					<outboundQueueBridge
						outboundQueueName="OutBoundQueueBridgeXBeanTest" />
				</outboundQueueBridges>
			</jmsQueueConnector>
		</jmsBridgeConnectors>

...........
</broker>

	<bean id="remoteFactory"
		class="org.apache.activemq.ActiveMQConnectionFactory">
		<property name="brokerURL" value="ssl://remoteHostName:61617" />
		<property name="userName" value="guest" />
		<property name="password" value="password" />
	</bean>


Is there any other way to configure authentication for bridge connection?

Any help appreciated,

Meena
-- 
View this message in context: http://www.nabble.com/Bridge-Authentication-problem---ActiveMQ_5.1-tp18224701p18224701.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message