activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hans Bausewein (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-1828) Classpath in "jaxb-impl" META-INF/MANIFEST.MF does not match included library
Date Fri, 27 Jun 2008 13:51:01 GMT
Classpath in "jaxb-impl" META-INF/MANIFEST.MF does not match included library
-----------------------------------------------------------------------------

                 Key: AMQ-1828
                 URL: https://issues.apache.org/activemq/browse/AMQ-1828
             Project: ActiveMQ
          Issue Type: Bug
    Affects Versions: 5.1.0
         Environment: JBoss 4.0.5 GA
            Reporter: Hans Bausewein
         Attachments: jaxb-impl-MANIFEST.diff

When I first deployed and used the resource adapter, it could not find it's "jaxb-api-2.1.jar".

See the attached "jaxb-impl-MANIFEST.diff".

The META-INF/MANIFEST.MF of jaxb-impl-2.0.3.jar lists the classpath as:

Class-Path: jaxb-api.jar activation.jar jsr173_1.0_api.jar jaxb1-impl.
 jar

... but the file names is "jaxb-api-2.1.jar" 


Applying the patch to the META-INF/MANIFEST.MF in "jaxb-api-2.1.jar" and updating that jar
in "activemq-rar-5.1.0.rar" resolves the problem.

I could reproduce the failing jar with the 5.1.0 source, but I couldn't find out where in
the build process it fails.
Maybe it's the  "jaxb-impl" pom in the maven repository.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message