activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Schooler (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (AMQ-1377) amq.js should not have a dependency on prototype.js
Date Fri, 13 Jun 2008 14:38:00 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-1377?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=43456#action_43456
] 

dan the man edited comment on AMQ-1377 at 6/13/08 7:37 AM:
------------------------------------------------------------

Jim's modified files require either the amq_jquery_adapter or the amq_prototype_adapter, which
in turn require jquery or prototype, respectively. The include order of the .js files is also
important. You must first include prototype or jquery, then include the respective adapter,
then include the modified amq.js

If you eliminate the amq_prototype_adapter.js completely then amq.js will definitely not work
because it requires one of the adapters to use the appropriate AJAX library.

I would suggest that you install the Firebug plugin in your Firefox web browser, set some
breakpoints in the javascript code and step through it to see what is happening.

      was (Author: dan the man):
    Jim's modified files require either the amq_jquery_adapter or the amq_prototype_adapter,
which in turn require jquery or prototype, respectively. The include order of the .js files
is also important. You must first include prototype or jquery first, then include the respective
adapter, then include the modified amq.js

If you eliminate the amq_prototype_adapter.js completely then amq.js will definitely not work
because it requires one of the adapters to use the appropriate AJAX library.

I would suggest that you install the Firebug plugin in your Firefox web browser, set some
breakpoints in the javascript code and step through it to see what is happening.
  
> amq.js should not have a dependency on prototype.js
> ---------------------------------------------------
>
>                 Key: AMQ-1377
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1377
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: Broker
>    Affects Versions: 5.0.0
>            Reporter: Jim Cook
>         Attachments: amq.js, amq.js, amq.js, amq_js.zip
>
>
> amq.js uses a script loading technique to include behavior.js, prototype.js and _amq.js.
The Behavior library is included only for the purposes of the chat client and is only GUI
in nature, so that should go. Also, Prototype is included for its AJAX functionality, however
everyone has their favorite javascript library and although I cut my teeth on prototype, I
use jQuery now. I certainly don't want amq.js to include prototype when I have a perfectly
good AJAX library already included in jQuery.
> IMHO, amq.js should include only the functionality of client-side javascript-enabled
JMS. The page author should include her AJAX library of choice (prototype, dojo, jquery, mootools,
etc.) and an adapter class that allows amq.js to use the particular ajax library.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message