activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jaya Srinivasan (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-1780) ActiveMQ broker does not automatically reconnect if the connection to the database is lost
Date Fri, 06 Jun 2008 20:46:00 GMT
ActiveMQ broker does not automatically reconnect if the connection to the database is lost
------------------------------------------------------------------------------------------

                 Key: AMQ-1780
                 URL: https://issues.apache.org/activemq/browse/AMQ-1780
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 5.0.0
         Environment: Windows 2003 Server
            Reporter: Jaya Srinivasan


hi

We are noticing that after any SQL Server restart or network blip between ActiveMQ and the
database, after the connection or the database comes back online activeMQ broker needs to
be restarted as well i.e it doesn't automatically re-establish connection to the database
as result any message send fails because the broker is still using the stale connection to
the database. 

Is this designed behaviour or a bug? we are using ActiveMQ 5.0.0 and the latest version of
the JSQLConnect database driver: version 5.7. The database we are using is MS SQL Server 2005


Right now, in our production environment any time we have network maintenance or database
restart we also have to restart the ActiveMQ broker which is not a good option for us. 

Also, We are using a single ActiveMQ broker and not the JDBC(Master/Slave) set up.

Issue details in

http://www.nabble.com/Database-connection-between-ActiveMQ-and-broker-td17321330s2354.html

Please let me know if I need to give more information

thanks
jaya


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message