activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: Trunk Build Fails
Date Tue, 22 Apr 2008 19:34:58 GMT
Sorry that just happened because I did a release build of ActiveMQ
(RC4) and the release pluging updates and checks in changes that break
things for a little while.. well it would work if the release was
voted on and pushed out to the mirrors but that has not happened yet.

I'll fix it in 2 seconds.


On Tue, Apr 22, 2008 at 3:12 PM, Jim Gomes <e.semog@gmail.com> wrote:
> I am still experiencing problems building the trunk.  I have modified my
>  command-line parameters as suggested by Rob, but it still fails.  Here are
>  my command-line parameters:
>
>  set MAVEN_OPTS=-Xmx1024M -Xms1024M
>  mvn -Dtest=false -DfailIfNoTests=false clean install
>
>  It builds for a bit, and then I get the following:
>
>  [INFO]
>  ------------------------------------------------------------------------
>  [INFO] Building ActiveMQ :: Console
>  [INFO]    task-segment: [install]
>  [INFO]
>  ------------------------------------------------------------------------
>  Downloading:
>  http://repo1.maven.org/maven2/org/apache/activemq/activemq-core/5.1.0/activemq-core-5.1.0-tests.jar
>  [INFO]
>  ------------------------------------------------------------------------
>  [ERROR] BUILD ERROR
>  [INFO]
>  ------------------------------------------------------------------------
>  [INFO] Failed to resolve artifact.
>
>  Missing:
>  ----------
>  1) org.apache.activemq:activemq-core:test-jar:tests:5.1.0
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.activemq
>  -DartifactId=activemq-core -Dversion=5.1.0 -Dclassifier=tes
>  ts -Dpackaging=test-jar -Dfile=/path/to/file
>
>   Alternatively, if you host your own repository you can deploy the file
>  there:
>       mvn deploy:deploy-file -DgroupId=org.apache.activemq
>  -DartifactId=activemq-core -Dversion=5.1.0 -Dclassifier=tests
>   -Dpackaging=test-jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>
>   Path to dependency:
>         1) org.apache.activemq:activemq-console:jar:5.2.-SNAPSHOT
>         2) org.apache.activemq:activemq-core:test-jar:tests:5.1.0
>
>  ----------
>  1 required artifact is missing.
>
>  for artifact:
>   org.apache.activemq:activemq-console:jar:5.2.-SNAPSHOT
>
>  from the specified remote repositories:
>   apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository),
>   central (http://repo1.maven.org/maven2)
>
>
>  [INFO]
>  ------------------------------------------------------------------------
>  [INFO] For more information, run Maven with the -e switch
>  [INFO]
>  ------------------------------------------------------------------------
>  [INFO] Total time: 1 minute 26 seconds
>  [INFO] Finished at: Tue Apr 22 11:28:51 PDT 2008
>  [INFO] Final Memory: 33M/89M
>  [INFO]
>  ------------------------------------------------------------------------
>
>  This is a brand-new SVN checkout of the HEAD revision.
>
>  Any help in trouble-shooting this would be appreciated.  This issue has been
>  introduced fairly recently within the last week or so.
>
>  - Jim
>



-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Open Source SOA
http://open.iona.com

Mime
View raw message