activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: createTemporaryQueue broken in 5.0 / 5.1?
Date Mon, 07 Apr 2008 16:47:02 GMT
Mind submitting a junit test case showing the failure?  Thx. Hiram

On Thu, Feb 28, 2008 at 10:14 AM, PseudoRoger <roger.fernberg@gmail.com> wrote:
>
>  I have 5.0.0 and snapshot: apache-activemq-5.1-20080227.125551-32.tar.gz.
>  Out of the box, start it on a local mac or linux,
>  cd example
>  ant requester
>
>  hands on the temporary destinations consumer.receive()
>
>  in another program, i do the same thing requester does, create a producer,
>  create a tmpqueue, then later in a single thread send using the producer
>  then invoke receive() on the tmpqueue.
>
>  I notice that in the admin console, the tmpqueue does NOT show up when i
>  invoke createTemporaryQueue() in my setup... but it DOES show up when the
>  recipient of this message gets it, generates a response and sends that to
>  the replyto, which is the destination of the tmp queue, at that point the
>  admin console shows the queue with 0 consumers and 1 message pending.
>
>
>
>  --
>  View this message in context: http://www.nabble.com/createTemporaryQueue-broken-in-5.0---5.1--tp15737274s2354p15737274.html
>  Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>
>



-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Open Source SOA
http://open.iona.com

Mime
View raw message