activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Davies (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (AMQ-885) setUseAsyncSend default value causes bad performance if the client and the server are not on the same machine
Date Thu, 10 Apr 2008 06:50:43 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-885?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rob Davies reassigned AMQ-885:
------------------------------

    Assignee: Rob Davies

> setUseAsyncSend default value causes bad performance if the client and the server are
not on the same machine
> -------------------------------------------------------------------------------------------------------------
>
>                 Key: AMQ-885
>                 URL: https://issues.apache.org/activemq/browse/AMQ-885
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 3.2.2
>         Environment: WINDOWS NT server 2003
>            Reporter: olivier benichou
>            Assignee: Rob Davies
>             Fix For: 5.2.0
>
>   Original Estimate: 20 minutes
>  Remaining Estimate: 20 minutes
>
> When creating ActiveMQConnectionFactory instance, one shall set UseAsyncSend attribute
to false,
> otherwise performance are very poor if the server and the client are not running on the
same machine.
> The question is : Is it normal to have to set UseAsyncSend to false if we want to have
good performance ?
> 	ActiveMQConnectionFactory factory = new ActiveMQConnectionFactory(brokerURL);
>     	factory.setUseAsyncSend(false);
> Thanks

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message