activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Davies (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-1483) unsuccessful NetworkConnector connections leak threads
Date Wed, 09 Apr 2008 09:48:32 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-1483?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rob Davies resolved AMQ-1483.
-----------------------------

    Fix Version/s: 5.1.0
       Resolution: Fixed

Recommend you use 5.1 when its released

> unsuccessful NetworkConnector connections leak threads
> ------------------------------------------------------
>
>                 Key: AMQ-1483
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1483
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Connector
>    Affects Versions: 4.1.1
>            Reporter: Norbert Kiesel
>            Assignee: Rob Davies
>             Fix For: 5.1.0
>
>
> I have a pair of (embedded) brokers connected via a NetworkConnector:
>     <networkConnectors>
>       <networkConnector name="secondary" uri="static://(ssl://192.168.4.3:4081)" networkTTL="5"
prefetchSize="1"/>
>     </networkConnectors>
> When the receiving broker is not running, the sender tries to reconnect every 5 seconds.
 While doing that, it leaks threads (seems like about 2 threads per minute). Checking with
jconsole, all hanging threads are doing:
> Name: JMX server connection timeout 85
> State: TIMED_WAITING on [I@38f04c
> Total blocked: 0  Total waited: 143
> Stack trace: 
> java.lang.Object.wait(Native Method)
> com.sun.jmx.remote.internal.ServerCommunicatorAdmin$Timeout.run(ServerCommunicatorAdmin.java:150)
> java.lang.Thread.run(Thread.java:595)
> The threads that are created every 5 seconds look like this in jconsole:
> Name: Thread-2060
> State: TIMED_WAITING on java.lang.Object@a06577
> Total blocked: 0  Total waited: 1
> Stack trace: 
> java.lang.Object.wait(Native Method)
> org.apache.activemq.transport.discovery.simple.SimpleDiscoveryAgent$1.run(SimpleDiscoveryAgent.java:139)
> If that issue is fixed in 5.0: can someone please tell me if/how that fix can be backported
to 4.1.1?
> Best,
>   Norbert

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message