activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Jovanovic <ivan.jovano...@gmail.com>
Subject Re: Starting ActiveMQ web console problem
Date Thu, 24 Apr 2008 21:39:53 GMT

Yes it works, thanks a lot.



Dejan Bosanac wrote:
> 
> Hi,
> 
> it seems like Gentoo-related problem. I've read somewhere that maybe if
> you
> have gcc java installed on the system, this could be a problem. Anyway,
> try
> using bioConnector instead, it should be working fine
> 
>    <connectors>
>      <bioConnector port="993" />
>    </connectors>
> 
> 
> Cheers
> -- 
> Dejan Bosanac
> www.scriptinginjava.net
> 
> On Wed, Apr 23, 2008 at 11:43 AM, Ivan Jovanovic
> <ivan.jovanovic@gmail.com>
> wrote:
> 
>>
>> Hi guys,
>>
>> I have a problem with starting ActiveMQ web console. I have this
>> configuration
>>
>> <!-- tilllate Stomp Configuration -->
>> <beans
>>  xmlns="http://www.springframework.org/schema/beans"
>>  xmlns:amq="http://activemq.org/config/1.0"
>>  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>  xsi:schemaLocation="http://www.springframework.org/schema/beans
>> http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
>>  http://activemq.org/config/1.0
>> http://activemq.apache.org/schema/activemq-core.xsd
>>  http://activemq.apache.org/camel/schema/spring
>> http://activemq.apache.org/camel/schema/spring/camel-spring.xsd">
>>
>>  <!-- Allows us to use system properties as variables in this
>> configuration
>> file -->
>>  <bean
>>
>> class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer"/>
>>
>>  <broker xmlns="http://activemq.org/config/1.0" brokerName="localhost"
>> persistent="true" useShutdownHook="false"
>> dataDirectory="${activemq.base}/data">
>>
>>    <!-- The transport connectors ActiveMQ will listen to -->
>>    <transportConnectors>
>>       <transportConnector name="stomp" uri="stomp://localhost:61613"/>
>>    </transportConnectors>
>>
>>    <!-- Allow persistent messages -->
>>    <persistenceAdapter>
>>      <amqPersistenceAdapter directory="${activemq.base}/activemq-data"
>> maxFileLength="32mb"/>
>>    </persistenceAdapter>
>>
>>  </broker>
>>
>>
>>  <!-- An embedded servlet engine for serving up the Admin console -->
>>  <jetty xmlns="http://mortbay.com/schemas/jetty/1.0">
>>    <connectors>
>>      <nioConnector port="993" />
>>    </connectors>
>>
>>    <handlers>
>>      <webAppContext contextPath="/admin"
>> resourceBase="${activemq.base}/webapps/admin" logUrlOnStart="true" />
>>    </handlers>
>>  </jetty>
>>
>> </beans>
>>
>> And when I comment out <jetty></jetty> part it starts ok. But when I
try
>> to
>> run the console it throws WARN with exception
>>
>> WARN  log                            - failed
>> org.mortbay.jetty.nio.SelectChannelConnector$1@d19cdf
>> java.io.IOException: Function not implemented
>>
>> I'm trying to run on Gentoo, linux kernel 2.6.11, Sun-JDK 1.6.0.05
>>
>> I read about the new NIO implementation in linux kernel 2.6 and support
>> for
>> it in Java 1.6 but probably it should be no problem. I presume that there
>> is
>> some fallback to proper NIO protocol.
>>
>> Thanks in advance for your answers.
>> Cheers,
>> Ivan
>> --
>> View this message in context:
>> http://www.nabble.com/Starting-ActiveMQ-web-console-problem-tp16833574s2354p16833574.html
>> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>>
>>
> 
> 
> -----
> Dejan Bosanac
> www.scriptinginjava.net
> 

-- 
View this message in context: http://www.nabble.com/Starting-ActiveMQ-web-console-problem-tp16833574s2354p16853278.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message