activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Davies (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (AMQ-867) JMX Management Console Not Working As Documented
Date Wed, 09 Apr 2008 18:37:32 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-867?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rob Davies reassigned AMQ-867:
------------------------------

    Assignee: Rob Davies

> JMX Management Console Not Working As Documented
> ------------------------------------------------
>
>                 Key: AMQ-867
>                 URL: https://issues.apache.org/activemq/browse/AMQ-867
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 4.0.1, 4.0.2
>         Environment: Linux nuk 2.6.15-23-amd64-generic #1 SMP PREEMPT Tue May 23 13:45:47
UTC 2006 x86_64 GNU/Linux
>            Reporter: Douglas A. Seifert
>            Assignee: Rob Davies
>             Fix For: 5.1.0
>
>
> Starting in 4.0.1 and continuing in a snapshot 4.0.2 release, the ActiveMQ JMX management
console is not working as advertised.  In version 4.0, I would see the following message logged
to the console when starting activemq:
> INFO  ManagementContext              - JMX consoles can connect to service:jmx:rmi:///jndi/rmi://localhost:1099/jmxrmi
> In Version 4.0.1 and higher, I no longer see this message.
> When trying to connect to the broker using the jconsole program, in versions 4.0.1 and
higher, the following command does not work (get "Connection failed" message).
> jconsole service:jmx:rmi:///jndi/rmi://localhost:1099/jmxrmi
> However, in 4.0, it does work.
> With 4.0.1 and higher, I am able to execute jconsole with no arguments and pick the activemq
jvm from the dialog that pops up and access the managment mbeans just fine.
> A symptom of this problem in 4.0.1 and higher is that none of the command line tools
in the bin directory work.  Here is sample output:
> doug@nuk:~/tools/activemq/incubator-activemq-4.0.2/bin$ ./shutdown
> ACTIVEMQ_HOME: /home/doug/tools/activemq/incubator-activemq-4.0.2
> ERROR: java.lang.RuntimeException: Failed to execute stop task. Reason: java.io.IOException:
Failed to retrieve RMIServer stub: javax.naming.ServiceUnavailableException [Root exception
is java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:
>         java.net.ConnectException: Connection refused]
> ERROR: java.lang.Exception: java.io.IOException: Failed to retrieve RMIServer stub: javax.naming.ServiceUnavailableException
[Root exception is java.rmi.ConnectException: Connection refused to host: localhost; nested
exception is:
>         java.net.ConnectException: Connection refused]
> With 4.0, all command line tools work as expected.
> Not sure what is going on here, but something changed in versions 4.0.1 and above.
> One last note: in 4.0.1 and higher, I uncommented the managementContext tag in the activemq.xml
file, but that had no effect.  The problem remained as described here.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message