activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ramit Arora <ramit.ar...@gmail.com>
Subject Re: Publishing hangs on the Topic without Exception in ActiveMQ 5.0
Date Wed, 26 Mar 2008 06:47:51 GMT

Thanks for the quick reply Sachin, I'll try these things out. 

Thanks,
Ramit
 

SachinMulaye wrote:
> 
> Ya i Fixed the problem.
> We made couple of changes :
> On the publishing side we are not creating sesssion / publisher everytime
> we connect. We are keeping it in the cache.
> On the Client side we checked the session.DispatchAsync = true;
> 
> Sachin
> 
> 
> Ramit Arora wrote:
>> 
>> Hey Sachin,
>> Were you able to fix this problem? I am facing a similar issue with
>> master/slave.
>> 
>> SachinMulaye wrote:
>>> 
>>> Hi,
>>> 
>>> We are using ActiveMQ 5.0 on Solaries in Prodn.
>>> We are continously publishing messages on the topic, we have around 90
>>> subscribers. These are Non-Persistence messages. We have 2 Activemq
>>> servers running, one is the master and other is the slave.
>>> After a day or two the publishing hangs we dont get any exception while
>>> publishing. The only solution we have is to restart our ActiveMq
>>> Servers. 
>>> 
>>> What is the possible root cause for publishing to hang?
>>> How can i check the number of messages on the topic? The API doesnt
>>> provide the any method to find the number of messages on the topic.
>>> 
>>> Let me know if anyone needs more information.
>>> 
>>> Sachin
>>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Publishing-hangs-on-the-Topic-without-Exception-in-ActiveMQ-5.0-tp15976535s2354p16296530.html
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message