activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mittler, Nathan" <nathan.mitt...@sensis.com>
Subject RE: Unknown type for ow_create_object(type, pool)
Date Wed, 30 Jan 2008 18:20:52 GMT
To be honest, I'm not sure if that client is being maintained.  I
recommend using ActiveMQ-CPP (http://activemq.apache.org/cms/) 

Regards,
Nate

> -----Original Message-----
> From: Thomas Gabrysch [mailto:tgabrysch@smapper.com]
> Sent: Wednesday, January 30, 2008 9:45 AM
> To: dev@activemq.apache.org
> Subject: Unknown type for ow_create_object(type, pool)
> 
> 
> I downloaded the source:
> 
>     Revision 615957: /activemq/sandbox/openwire-c/src
> 
> and compiled and linked the code on Linux - which was not straight
> forward.
> 
> I have the message broker running on a Windows XP box.
> 
> Here is the problem:
> 
> When running the example program, the following calling sequence takes
> place:
> 
> amqcs_connect()
>   -> ow_unmarshal_WireFormatInfo ()
>   -> ow_unmarshal_nested_object ()
>   -> ow_create_object(type, pool)
> 
> with type=99, which is not defined.
> 
> So ow_create_object () returns the NULL pointer instead of a valid
> object pointer.
> 
> Any hints how to go from here?
> 
> --
> View this message in context: http://www.nabble.com/Unknown-type-for-
> ow_create_object%28type%2C-pool%29-tp15187762s2354p15187762.html
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message