activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: stomp php client using activemq 4.1.1
Date Thu, 29 Nov 2007 15:33:00 GMT
Hi,

Are your using auto acking or are you manually acking the messages?
Manually acking the messages is the only way to garantee that no
message loss will occur.


On Nov 29, 2007 6:05 AM, jawed <javeds@uk.specsavers.com> wrote:
>
> Hello,
>
> Re: Loosing messages using the stomp feature in activemq 4.1.1
>
> 1. I am using activemq 4.1.1 as my broker and a POJO as my consumer
> 2. I am sending messages from a php stomp client taken from
> https://svn.codehaus.org/stomp/trunk/php/
>
> Scenario:
> I am sending messages from the php client using the stomp protocol to my
> activemq broker. After sending all messages I then run my consumer, only to
> find some of the messages are being consumed. It seems to happen when I send
> three or more messages, and the messages that are lost is random i.e. the
> lost messages do not follow a sequence. Is this a known issue?
>
> Also, I was wondering if turning on the persistence feature from the php
> client would guarantee delivery, if so, how can I turn on messaging
> persistence from the php client using the header properties, is it a string
> if so what string or an object if so which object?
>
> Thanks for your time
>
>
>
>
>
> --
> View this message in context: http://www.nabble.com/stomp-php-client-using-activemq-4.1.1-tf4896391s2354.html#a14023401
> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>
>



-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Open Source SOA
http://open.iona.com

Mime
View raw message