activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "gkathiravan (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (AMQ-305) Add Postgres Support
Date Sat, 17 Nov 2007 09:15:26 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-305?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

gkathiravan reopened AMQ-305:
-----------------------------


SET AUTOCOMMIT TO OFF is no longer supported in Postgre8.0

    When i start the broker with JDBCPersistence the following error occurs

Nov 17, 2007 2:21:27 PM org.apache.activemq.store.jdbc.JDBCPersistenceAdapter createAdapter
INFO: Database driver recognized: [postgresql_native_driver]
Exception in thread "main" java.io.IOException: ERROR:  SET AUTOCOMMIT TO OFF is no longer
supported

	at org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:43)
	at org.apache.activemq.store.jdbc.TransactionContext.getConnection(TransactionContext.java:62)
	at org.apache.activemq.store.jdbc.TransactionContext.begin(TransactionContext.java:147)
	at org.apache.activemq.store.jdbc.JDBCPersistenceAdapter.start(JDBCPersistenceAdapter.java:156)
	at com.glenwood.Queue.StartBroker.createPersistenceAdapter(StartBroker.java:49)
	at com.glenwood.Queue.StartBroker.main(StartBroker.java:28)
Caused by: java.sql.SQLException: ERROR:  SET AUTOCOMMIT TO OFF is no longer supported

	at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java:131)
	at org.postgresql.jdbc1.AbstractJdbc1Connection.ExecSQL(AbstractJdbc1Connection.java:482)
	at org.postgresql.jdbc1.AbstractJdbc1Connection.ExecSQL(AbstractJdbc1Connection.java:461)
	at org.postgresql.jdbc1.AbstractJdbc1Connection.setAutoCommit(AbstractJdbc1Connection.java:953)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.postgresql.ds.common.PooledConnectionImpl$ConnectionHandler.invoke(PooledConnectionImpl.java:360)
	at $Proxy0.setAutoCommit(Unknown Source)
	at org.apache.activemq.store.jdbc.TransactionContext.getConnection(TransactionContext.java:58)
	... 4 more




> Add Postgres Support
> --------------------
>
>                 Key: AMQ-305
>                 URL: https://issues.apache.org/activemq/browse/AMQ-305
>             Project: ActiveMQ
>          Issue Type: New Feature
>          Components: Message Store
>            Reporter: Hiram Chirino
>             Fix For: 3.1
>
>
>  The JDBC Message Store should support Postgresql

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message