activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez (JIRA)" <j...@apache.org>
Subject [jira] Reopened: (AMQ-907) Make the ActiveIO dependency and optional dependency.
Date Mon, 01 Oct 2007 07:24:23 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-907?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Carlos Sanchez reopened AMQ-907:
--------------------------------


4.1.1 in maven repo still lists activeio-core as required

http://repo1.maven.org/maven2/org/apache/activemq/activemq-parent/4.1.1/activemq-parent-4.1.1.pom
http://repo1.maven.org/maven2/org/apache/activemq/activemq-core/4.1.1/activemq-core-4.1.1.pom

> Make the ActiveIO dependency and optional dependency.
> -----------------------------------------------------
>
>                 Key: AMQ-907
>                 URL: https://issues.apache.org/activemq/browse/AMQ-907
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: Broker
>            Reporter: Hiram Chirino
>            Assignee: Hiram Chirino
>             Fix For: 4.1.0
>
>
> Need to move some core classes that are in activeio to activemq
> so that it is not needed to run.  Right now the only real
> functionality that it provides that is optional is the journal
> implementation.
> Everything else that is use from activeio are just abstract interfaces, and I think
> those need to be moved/copied to ActiveMQ.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message