activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-907) Make the ActiveIO dependency and optional dependency.
Date Mon, 01 Oct 2007 12:15:23 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-907?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hiram Chirino resolved AMQ-907.
-------------------------------

       Resolution: Fixed
    Fix Version/s:     (was: 4.1.0)
                   5.0.0

Ah.. it has become optional in the 5.x branch of code.  Not the 4.x.

> Make the ActiveIO dependency and optional dependency.
> -----------------------------------------------------
>
>                 Key: AMQ-907
>                 URL: https://issues.apache.org/activemq/browse/AMQ-907
>             Project: ActiveMQ
>          Issue Type: Improvement
>          Components: Broker
>            Reporter: Hiram Chirino
>            Assignee: Hiram Chirino
>             Fix For: 5.0.0
>
>
> Need to move some core classes that are in activeio to activemq
> so that it is not needed to run.  Right now the only real
> functionality that it provides that is optional is the journal
> implementation.
> Everything else that is use from activeio are just abstract interfaces, and I think
> those need to be moved/copied to ActiveMQ.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message