activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike.Gingell" <>
Subject ActiveMQ-CPP Build problems
Date Wed, 12 Sep 2007 18:40:33 GMT

I am not able to build ActiveMQ-CPP.  I have tried using the 2.1 release and
also from the latest trunk (rev 570555)

I have tried using cygwin, but fails horribly.  (g++ version

/usr/share/aclocal/cppunit.m4:4: warning: underquoted definition of
/usr/share/aclocal/cppunit.m4:4:   run info '(automake)Extending aclocal'
/usr/share/aclocal/cppunit.m4:4:   or see
Unmatched [ in regex; marked by <-- HERE in
and so on.....
N_PAPER_SIZE$|^DX_ENV$|^LIBOBJS$|^LTLIBOBJS$/ at /usr/bin/autom4te-2.61 line
, <GEN13> line 3999.
autoreconf-2.61: /usr/bin/autoconf-2.61 failed with exit status: 1

I have also tried using the latest windows platform SDK, (Microsoft (R)
32-bit C/C++ Optimizing Compiler Version 14.00.50727.762 for 80x86) but I
also get many compile errors.

For example:
Connector.h(69) : see declaration of
..\src\main\activemq\connector\openwire\OpenWireConnector.cpp(294) : error
: 'DISCONNECTED' : undeclared identifier
..\src\main\activemq\connector\openwire\OpenWireConnector.cpp(318) : error
: 'createSession' : member function not declared in
"Build log was saved at
vs2005-activemq - 194 error(s), 2 warning(s)"

Can someone out there provide me with the correct tool configuration so that
I can build this beast!

A cygwin makefile or configure script would be nice.
View this message in context:
Sent from the ActiveMQ - Dev mailing list archive at

View raw message