activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Co (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-1363) activemq/conf/log4j.properties does not seem to get recognized
Date Thu, 16 Aug 2007 07:13:23 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-1363?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_39952
] 

Adrian Co commented on AMQ-1363:
--------------------------------

Yeah. I just did an svn update.

The previous log4j.properties has a:

log4j.appender.stdout.threshold=INFO

which limits the threshold for the stdout appender to INFO. Even though, the root logger is
set to DEBUG. I've modified the log4j.properties file in the assembly module to not use it.
Here's the complete config:

log4j.rootLogger=DEBUG, stdout, out
log4j.logger.org.apache.activemq.spring=WARN
log4j.logger.org.springframework=WARN
log4j.logger.org.apache.xbean.spring=WARN

# When debugging or reporting problems to the ActiveMQ team,
# comment out the above lines and uncomment the next.

#log4j.rootLogger=DEBUG, out, stdout

# Or for more fine grained debug logging uncomment one of these
#log4j.logger.org.apache.activemq=DEBUG
#log4j.logger.org.apache.camel=DEBUG



#The logging properties used during tests..
# CONSOLE appender not used by default
log4j.appender.stdout=org.apache.log4j.ConsoleAppender
log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
log4j.appender.stdout.layout.ConversionPattern=%-5p %-30.30c{1} - %m%n
#log4j.appender.stdout.threshold=INFO

# File appender
log4j.appender.out=org.apache.log4j.RollingFileAppender
log4j.appender.out.file=${activemq.base}/data/activemq.log
log4j.appender.out.maxFileSize=1024KB
log4j.appender.out.maxBackupIndex=5
log4j.appender.out.append=true
log4j.appender.out.layout=org.apache.log4j.PatternLayout
log4j.appender.out.layout.ConversionPattern=%d [%-15.15t] %-5p %-30.30c{1} - %m%n

> activemq/conf/log4j.properties does not seem to get recognized
> --------------------------------------------------------------
>
>                 Key: AMQ-1363
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1363
>             Project: ActiveMQ
>          Issue Type: Bug
>            Reporter: James Strachan
>            Assignee: Adrian Co
>
> Try taking a binary build; enabling debug logging by editing activemq/conf/log4j.properties,
then rerunning the broker. I get no change!
> BTW I've patched the activemq-core-*-tests.jar to not include a log4j.properties file.
Also I tried adding the activemq/conf directory explicitly in the console - to no avail.
> I also tried zapping the activeio jars and grepping the jars to see if any had any included
log4j.properties files - to no avail

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message