activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Tsigelnik (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-1369) discovery transport set wrong URI to DiscoveryAgentFactory
Date Wed, 22 Aug 2007 15:11:22 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-1369?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Tsigelnik resolved AMQ-1369.
-----------------------------------

    Resolution: Won't Fix

I see! Just need to set URI like dns://mq1:1234

> discovery transport set wrong URI to DiscoveryAgentFactory
> ----------------------------------------------------------
>
>                 Key: AMQ-1369
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1369
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Connector, Transport
>    Affects Versions: 4.1.1
>            Reporter: Dmitry Tsigelnik
>
> I developed another discovery agent and received Exception that cannot find aget "discovery".
> Threre is wrong URI set to DiscoveryAgentFactory.
> My configurartion 
> <networkConnectors>
>      
>       <networkConnector name="default-nc" uri="discovery:dns://mq1:61616" failover="true"/>
>       
>     </networkConnectors>
> Right URI is dns://mq1:61616, but it set full URI whith "discovery" prefix
> Workaround is add file "discovery" to META-INF and URI change to discovery://mq1:61616

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message