activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Davies (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-975) Setting "time to live" to >0 fails delivery from linux to window
Date Mon, 30 Jul 2007 21:05:49 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-975?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rob Davies resolved AMQ-975.
----------------------------

       Resolution: Cannot Reproduce
    Fix Version/s: 5.0.0

> Setting "time to live" to >0 fails delivery from linux to window
> ----------------------------------------------------------------
>
>                 Key: AMQ-975
>                 URL: https://issues.apache.org/activemq/browse/AMQ-975
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: JMS client
>    Affects Versions: 4.0, 4.0.1
>         Environment: Linux, window XP
>            Reporter: Wallaec Wong
>            Assignee: Rob Davies
>             Fix For: 5.0.0
>
>
> I found this problem on 4.0 and 4.0.1 running on Linux. 
> Problem reproduction steps: 
> 1. start activemq server on a linux server 
> 2. start a consumer client on a window XP 
> 3. start a producer client on same linux machine, setting timeToLive to any value >
0 
> 4. consumer client will not receive any messages 
> 5. set the time to live to 0, the consumer client will receive messages, or 
> 6. set time to live to 0 or not, consumer client running on linux will receive messages
too, or 
> 7. no problem too if producer runs on xp and consumer runs on linux 
> And apparently it does not really matter where the activemq server runs, linix or xp.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message