activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-1276) need the spring.schemas file backporting to 4.1 to use the new 4.1.2 generated schema
Date Thu, 14 Jun 2007 12:25:33 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-1276?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_39408
] 

James Strachan commented on AMQ-1276:
-------------------------------------

I've just brought up this issue on the dev list...
http://www.nabble.com/Handling-XSDs-and-Spring-2-XML-processing-etc.-tf3921424s2354.html


its basically up to the user to choose either the exact version they want - or the generic
version (activemq-core.xsd) which is then resolved against the classpath's XSD.

I hear you though - once a versioned XSD is released, we shouldn't change it. Though we could,
possibly, introduce an alias folks can use if they like (e.g. activemq-core-4.x.xsd) for the
'latest'.

Feel free to jump on the dev thread...
http://www.nabble.com/Handling-XSDs-and-Spring-2-XML-processing-etc.-tf3921424s2354.html


The only reason I meantioned it in this JIRA was so that the entity resolver matches against
activemq-core.xsd and activemq-core-4.1.2.xsd etc



> need the spring.schemas file backporting to 4.1 to use the new 4.1.2 generated schema
> -------------------------------------------------------------------------------------
>
>                 Key: AMQ-1276
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1276
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 4.1.1
>            Reporter: James Strachan
>            Assignee: Adrian Co
>            Priority: Critical
>             Fix For: 4.1.2
>
>
> as per AMQ-1016, we need a spring.schemas file generated which allows folks to use the
XSD http://activemq.apache.org/schema/activemq-core.xsd in their XML which is mapped to http://activemq.apache.org/schema/activemq-core-4.1.2.xsd
> Ditto if they use http://activemq.apache.org/schema/activemq-core-4.1.1.xsd then it should
be resolved locally from the jar (like 5.0 now does)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message