activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rakesh Kumar <rakeshkr...@yahoo.co.in>
Subject Re: Getting exception in creating the session for the receivers...
Date Wed, 13 Jun 2007 17:25:07 GMT
Can any one respond please. I am stuck here and not able to test my sender and receiver.

I am using ZThread to run the receiver. Is there any problem using ZThread with activemq.

I am always getting this exception Message:
response from futureResponse was invalid
        FILE:\src_org\main\activemq\transport\filters\ResponseCorrelator.cpp, LINE: 146
        FILE:\activemq-2.1\src\main\activemq\transport\filters\ResponseCorrelator.cpp, LINE:
153
        FILE:\activemq-2.1\src\main\activemq\connector\openwire\OpenWireFormatNegotiator.cpp,
LINE: 105
        FILE:\activemq-2.1\src\main\activemq\connector\openwire\OpenWireConnector.cpp, LINE:
1468
        FILE:\activemq-2.1\src\main\activemq\connector\openwire\OpenWireConnector.cpp, LINE:
692
        FILE:\activemq-2.1\src\main\activemq\core\ActiveMQSession.cpp, LINE: 265
        FILE:\activemq-2.1\src\main\activemq\core\ActiveMQSession.cpp, LINE: 271
        FILE:\activemq-2.1\src\main\activemq\core\ActiveMQSession.cpp, LINE: 191


If you need any more info please let me know.

Thanks in advance.

~Rakesh
----- Original Message ----
From: Rakesh Kumar <rakeshkrcse@yahoo.co.in>
To: dev@activemq.apache.org
Sent: Tuesday, 12 June, 2007 8:58:11 PM
Subject: Re: Getting exception in creating the session for the receivers...

I am also attaching the error message that i get during debugging while creating the consumer
using the session.


~Rakesh


----- Original Message ----
From: Rakesh Kumar <rakeshkrcse@yahoo.co.in>
To: dev@activemq.apache.org
Sent: Tuesday, 12 June, 2007 8:43:59 PM
Subject: Re: Getting exception in creating the session for the receivers...




Hi,

I have attached the code snippet of run method of Receiver that i am using.

 

Little more description of the problem:- 

1) Now i see sometime session got created but while creating the consumer it throws exception.

2) when i change the name of the queue for producer and consumer then they start fine, but
i can see messages coming to the consumer when send the message to the broker through different
producer (created seperately), seems to me session has been created properly.

 

Many thanks in advance...

 

~Rakesh



----- Original Message ----
From: Timothy Bish <tim.bish@sensis.com>
To: dev@activemq.apache.org
Sent: Tuesday, 12 June, 2007 5:06:13 PM
Subject: Re: Getting exception in creating the session for the receivers...


Can you attach a small sample that demonstrates the problem.  Have you
tried the same code using a static library using the official 2.0.1
release?  SVN Trunk is not a release and is not guaranteed to work, its
a work in progress.  

On Tue, 2007-06-12 at 16:59 +0530, Rakesh Kumar wrote:
> Hi,
> 
> I am using tcp port 61616 and the brokerURL that i am passing is 
> 
> "tcp://127.0.0.1:61616?wireFormat=openwire&transport.useAsyncSend=true";    
> 
> 
> 
> Strange behavior that i see is when i start only sender or receiver
> this problem does not occur. this occur only when they start on the
> same queue.
> 
> 
> 
> I am using 4.1 broker and  2.1 client (I have downloaded the source from svn and have
built the dll of activemq-cpp) 
> 
> 
> Please let me know if you need any other
 information.
> 
> Note:- I have created VS2003 project for this and have created the dll of activemq from
VS2003 itself.
> Same problem is happening in VS2005 build dlls also.
> 
> 
> ~Rakesh
> 
> ----- Original Message ----
> From: Albert Strasheim <fullung@gmail.com>
> To: dev@activemq.apache.org
> Sent: Tuesday, 12 June, 2007 4:44:26 PM
> Subject: Re: Getting exception in creating the session for the receivers...
> 
> Hello
> 
> On Tue, 12 Jun 2007, Rakesh Kumar wrote:
> 
> > To Add in here i am getting the stack trace as follows
> > 
> > In the RunMethod Exception
> > response from futureResponse was invalid
> >         FILE: \activemq-2.1\src_org\main\activemq\transport\filters\ResponseCorrelator.cpp,
LINE: 146
> > 
> > Thanks in advance...
> 
>
 Just guessing here, but are possibly trying to use the Openwire wire 
> protccol to connect to the Stomp port on the broker, i.e. port 61613 
> instead of port 61616?
> 
> Cheers,
> 
> Albert
> 
> 
> 
> 
> 
> 
> 
>       Download prohibited? No problem! To chat from any browser without download, Click
Here: http://in.messenger.yahoo.com/webmessengerpromo.php













Download prohibited? No problem! CHAT from any browser, without download.






	


       Download prohibited? No problem! CHAT from any browser, without download.





      Did you know? You can CHAT without downloading messenger. Click here http://in.messenger.yahoo.com/webmessengerpromo.php
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message