activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Endre Stølsvik (JIRA) <j...@apache.org>
Subject [jira] Commented: (AMQ-1276) need the spring.schemas file backporting to 4.1 to use the new 4.1.2 generated schema
Date Thu, 14 Jun 2007 12:14:33 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-1276?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_39407
] 

Endre Stølsvik commented on AMQ-1276:
-------------------------------------

Just a heads-up: only the third of those (the 4.1.1) is up - but this might be mirroring-latency
or whatever?

BUT, I don't understand why the unversioned file should be mapped to the 4.1.2?? Isn't this
just BEGGING for trouble in the future, when someone comes along and "ah, this isn't pointing
to the last release - I'll just fix that", and all of a sudden existing installations (or
at least their developers IDEs, since the spring.schemas finally are working) are all of a
sudden not working anymore.

I think that this type of definition should be _absolutely distinct_ - the user should point
specifically at a specific version.

Further, there really shouldn't be any automatics involved whatsoever with the putting-these-out-on-web
procedure. When it is manually copied there, a release which uses it is given out to the public,
it is TOTALLY fixed, and that file will forever, and EVER, be set in stone. I mean, it is
even worse than re-releasing a new cut of ActiveMQ 4.1.1 without giving it any distinction
whatsoever in filenames, readmes and whatnots, that things have changed inside.

Releasing "just a little quick-fix", which happens to also make a change in the XSD on the
"fixed" location, will lead to the problems you got the last time around: Things actually
worked when you released it (the 4.1, was it?), they did, but then new commits came in, and
suddenly my working installation wasn't working anymore - since the damn file my config was
referring to suddenly had changed.

> need the spring.schemas file backporting to 4.1 to use the new 4.1.2 generated schema
> -------------------------------------------------------------------------------------
>
>                 Key: AMQ-1276
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1276
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 4.1.1
>            Reporter: James Strachan
>            Assignee: Adrian Co
>            Priority: Critical
>             Fix For: 4.1.2
>
>
> as per AMQ-1016, we need a spring.schemas file generated which allows folks to use the
XSD http://activemq.apache.org/schema/activemq-core.xsd in their XML which is mapped to http://activemq.apache.org/schema/activemq-core-4.1.2.xsd
> Ditto if they use http://activemq.apache.org/schema/activemq-core-4.1.1.xsd then it should
be resolved locally from the jar (like 5.0 now does)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message