activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rakesh Kumar <rakeshkr...@yahoo.co.in>
Subject Re: Getting exception in creating the session for the receivers...
Date Tue, 12 Jun 2007 11:29:09 GMT
Hi,

I am using tcp port 61616 and the brokerURL that i am passing is 

"tcp://127.0.0.1:61616?wireFormat=openwire&transport.useAsyncSend=true";    



Strange behavior that i see is when i start only sender or receiver
this problem does not occur. this occur only when they start on the
same queue.



I am using 4.1 broker and  2.1 client (I have downloaded the source from svn and have built
the dll of activemq-cpp) 


Please let me know if you need any other information.

Note:- I have created VS2003 project for this and have created the dll of activemq from VS2003
itself.
Same problem is happening in VS2005 build dlls also.


~Rakesh

----- Original Message ----
From: Albert Strasheim <fullung@gmail.com>
To: dev@activemq.apache.org
Sent: Tuesday, 12 June, 2007 4:44:26 PM
Subject: Re: Getting exception in creating the session for the receivers...

Hello

On Tue, 12 Jun 2007, Rakesh Kumar wrote:

> To Add in here i am getting the stack trace as follows
> 
> In the RunMethod Exception
> response from futureResponse was invalid
>         FILE: \activemq-2.1\src_org\main\activemq\transport\filters\ResponseCorrelator.cpp,
LINE: 146
> 
> Thanks in advance...

Just guessing here, but are possibly trying to use the Openwire wire 
protccol to connect to the Stomp port on the broker, i.e. port 61613 
instead of port 61616?

Cheers,

Albert







      Download prohibited? No problem! To chat from any browser without download, Click Here:
http://in.messenger.yahoo.com/webmessengerpromo.php
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message