activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pieter (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-1301) Problems with reconnecting broker to network of brokers after broker shutdown
Date Fri, 29 Jun 2007 11:44:33 GMT
Problems with reconnecting broker to network of brokers after broker shutdown
-----------------------------------------------------------------------------

                 Key: AMQ-1301
                 URL: https://issues.apache.org/activemq/browse/AMQ-1301
             Project: ActiveMQ
          Issue Type: Bug
          Components: Broker
    Affects Versions: 4.1.2
            Reporter: Pieter


When using a network of brokers, I get problems in the following scenario. Consider two brokers,
broker1 and broker2, connected to eachother (see config below). Everything works ok: durable
consumers on topics get messages sent to either server. The messages are all persistent.

The problems occur in this scenario:

1. Bring down one of the brokers, let's say broker2 (all consumers and producers connect to
the other server, without any problems)
2. Start the killed broker2 again
3. The broker2 reconnects to the network as expected
4. However, messages don't get propagated correctly on the network anymore. Consumers on broker1
don't get messages sent to broker2 anymore, and messages from broker2 get sent to broker1
over and over again. This can also be seen in the webconsole for example, where the number
of messages in the queue grows rapidly.

The only way to fix this is to kill all brokers, and remove the persistent message stores.
THis is unacceptable, since this loses messages.

Config is below:

<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:util="http://www.springframework.org/schema/util">
 
 <broker brokerName="broker1" useJmx="true" persistent="true" xmlns="http://activemq.org/config/1.0">
  
    <persistenceAdapter>
        <journaledJDBC journalLogFiles="5" dataDirectory="${activemq.base}/activemq-data"/>
    </persistenceAdapter>
  
    <transportConnectors>
       <transportConnector name="openwire" uri="tcp://localhost:61616"/>
       <transportConnector name="stomp"   uri="stomp://localhost:61627"/>
    </transportConnectors>
  
<networkConnectors>
		<networkConnector name="ha-network" uri="static://(tcp://localhost:61618)" networkTTL="5"/>
</networkConnectors>
</broker>



<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:util="http://www.springframework.org/schema/util">
 
 <broker brokerName="broker2" useJmx="true" persistent="true" xmlns="http://activemq.org/config/1.0">
  
    <persistenceAdapter>
        <journaledJDBC journalLogFiles="5" dataDirectory="${activemq.base}/activemq-data"/>
    </persistenceAdapter>
  
    <transportConnectors>
       <transportConnector name="openwire" uri="tcp://localhost:61618"/>
       <transportConnector name="stomp"   uri="stomp://localhost:61628"/>
    </transportConnectors>
  
<networkConnectors>
		<networkConnector name="ha-network" uri="static://(tcp://localhost:61616)" networkTTL="5"/>
</networkConnectors>
</broker>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message