activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: ActiveMQ 4.2 and IBM JRE 1.4
Date Fri, 25 May 2007 14:52:41 GMT
On 5/25/07, David D. Lucas <ddlucas@lse.com> wrote:
> First off, thanks to everyone who put together a great open source package
> like ActiveMQ.  I am very impressed with it.  Great Job!!!
>
> I am trying to deploy ActiveMQ 4.2 to WebSphere 5.1.  I was able to do
> this with ActiveMQ 4.1, but with 4.2 I am seeing the "Unsupported
> major.minor version 49.0" error.  I assume that the ActiveMQ classes or
> something it is dependent on is compiled with JRE 1.5 byte code instead of
> JRE 1.4.  My assumption, of course, is that 4.2 will continue to support
> JRE 1.4 backward compatibility.  If this is not correct, can someone
> document that or point me to the correct location?

4.2 or later is built with Java 5 by default; since on Java 5 the new
concurrency code is faster & less buggy.

We may get around to creating a separate distro of retrotranslated
jars for 1.4. (Patches most welcome!:)

http://activemq.apache.org/contributing.html

Until then you can just install the retrotranslator JIT in your JVM to
auto-swizzle any Java 5 jars.
http://retrotranslator.sourceforge.net/#jit


> While I am on the topic with WebSphere, is there a way to use the embedded
> broker on multiple web containers all pointing to the same JDBC
> persistence store?

Just deploy one :)

The issue is from web apps they usually can't see the same broker via
VM transport. So either use TCP, or put the ActiveMQ jars in the
system class path.

-- 
James
-------
http://macstrac.blogspot.com/

Mime
View raw message