activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elber <shah...@hotmail.fr>
Subject Network Bridge problem
Date Fri, 11 May 2007 09:09:01 GMT

Hello,
I've built the source grabbed by svn then I started the broker of Activemq
4.2-snapshot on two machines.
I want to connect the two brokers without the multicast discovery but by a
PTP connection.

_______________________________

IP adresses:
Broker1 (B1): 10.24.244.248
Broker2 (B2): 10.24.246.242

activemq.xml:
B1:
 
   <transportConnectors>
       <transportConnector name="openwire" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/>
       <transportConnector name="ssl"     uri="ssl://localhost:61617"/>
       <transportConnector name="stomp"   uri="stomp://localhost:61613"/>
       <transportConnector name="xmpp"    uri="xmpp://localhost:61222"/>
    </transportConnectors>

    <!-- The store and forward broker networks ActiveMQ will listen to -->
    <networkConnectors>
      <networkConnector name="default-nc" uri="multicast://default"/>
      <networkConnector name="PTP"
uri="static://(tcp://10.24.244.248:61616,tcp://10.24.246.242:61616)" />
    </networkConnectors>

B2:

   <transportConnectors>
       <transportConnector name="openwire" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/>
       <transportConnector name="ssl"     uri="ssl://localhost:61617"/>
       <transportConnector name="stomp"   uri="stomp://localhost:61613"/>
       <transportConnector name="xmpp"    uri="xmpp://localhost:61222"/>
    </transportConnectors>

    <!-- The store and forward broker networks ActiveMQ will listen to -->
    <networkConnectors>
      <networkConnector name="default-nc" uri="multicast://default"/>
      <networkConnector name="PTP"
uri="static://(tcp://10.24.246.242:61616,tcp://10.24.244.248:61616)" />
    </networkConnectors>

____________________________
When I start the brokers, the connection between them fails and I don't know
why.
this is the message displayed on the machine  of B1:

WARN  NetworkConnector               - Could not start network bridge
between: vm://localhost and: tcp://10.24.247.242:61616 due to:
java.net.SocketTimeoutException: connect timed out
INFO  DemandForwardingBridge         - localhost bridge to Unknown stopped
INFO  NetworkConnector               - Establishing network connection
between from vm://localhost to tcp://10.24.246.242:61616


Can you help me?

Thank you.
-- 
View this message in context: http://www.nabble.com/Network-Bridge-problem-tf3726274s2354.html#a10428418
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message