activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dhawan, Vikram \(LNG-DAY\)" <vikram.dha...@lexisnexis.com>
Subject RE: Load Balancer configuration
Date Mon, 09 Apr 2007 19:38:24 GMT
Hi James, 

Actually my AMQ clients are connecting to a VIP which is the load
balancers IP, and load balancer wants to ping and checks the AMQ
instance status before it routes the client call. That's why Load
balancer is sending ping to AMQ instances. 

Any idea, how should I configure AMQ instances.

Thanks!

Vik
-----Original Message-----
From: James Strachan [mailto:james.strachan@gmail.com] 
Sent: Monday, April 09, 2007 3:00 PM
To: dev@activemq.apache.org
Subject: Re: Load Balancer configuration

The ActiveMQ client sends ping commands anyway, so why does the load
balancer need to shove stuff down the same socket?

On 4/9/07, Dhawan, Vikram (LNG-DAY) <vikram.dhawan@lexisnexis.com>
wrote:
> Hi,
>
>
>
> I am trying to configure multiple AMQ instances with a Load balancer
> configuration for High availability. Load balancer I am using wants to
> Ping AMQ instances to do the keep-alive check.  I tried to set that
> keep-alive port to 61617/61616. every time Load Balancer pings, AMQ
> throws exception because this is not a real OpenWire/SSL
communication;
> but this approach works for few Hrs.
>
>
>
> But after some time AMQ gets tired of this ping and throws OutofMemory
> exception. I guess AMQ is growing in memory every time it throws the
> connection exception and not cleaning up properly.
>
>
>
> My question is how to manage such a configuration where AMQ's are
> configured behind a load balancer.
>
>
>
> Thanks!
>
>
>
>
>
> Vik
>
>
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message