activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arabinda <arabi...@nagarro.com>
Subject Re: Issues with sending and Recieve messages to a Queue
Date Thu, 12 Apr 2007 06:17:25 GMT

For example i have an MDB defined in jboss.xml
<message-driven>
         <ejb-name>PublishMDB</ejb-name>                       
         <destination-jndi-name>queue/PublishQueue</destination-jndi-name>

      </message-driven>

and i have define this queue in active-jms-ds.xml

i got the error 

 [org.jboss.ejb.EjbModule] Deploying PublishMDB
2007-04-12 01:14:35,832 WARN 
[org.jboss.ejb.plugins.jms.JMSContainerInvoker] JMS provider failure
detected: 
org.jboss.deployment.DeploymentException: Error during queue setup; - nested
throwable: (java.lang.ClassCastException:
org.apache.activemq.command.ActiveMQQueue)
	at
org.jboss.deployment.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:39)
	at
org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerCreate(JMSContainerInvoker.java:898)
	at
org.jboss.ejb.plugins.jms.JMSContainerInvoker.startService(JMSContainerInvoker.java:922)
	at
org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:272)
	at
org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:222)
	at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:585)

Have any one any idea why this happen. ?

In my application server container have both JMS(JbossMQ and ActiveMQ)

Thanks,
Arabinda


James.Strachan wrote:
> 
> There's not much to go on. Are there any issues in the log? What do
> things look like in JMX?
> 
> On 4/11/07, Arabinda <arabinda@nagarro.com> wrote:
>>
>> Hi ,
>> 1)I have integaret JBOSS  with ActiveMQ.
>> 2) create *-ds.xml to configure connection factory and inbound and
>> outbound
>> resources.
>> 3) I have One Session bean and 4 MDB to send and recive message .
>>   in jboss.xml i have defined destination-jndi-name for every MDB
>> .Assuming
>> on deployment it will create Queue
>>   and send/Recieve message in defined queues .
>>
>> But it is not  happen , it waits for long time , probably i miss
>> something ,
>> Can anyone help me to figure out what may be the problem.
>>
>> Thanks,
>> Arabinda
>> --
>> View this message in context:
>> http://www.nabble.com/Issues-with-sending-and-Recieve-messages-to-a-Queue-tf3561376s2354.html#a9946223
>> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> 
> James
> -------
> http://radio.weblogs.com/0112098/
> 
> 

-- 
View this message in context: http://www.nabble.com/Issues-with-sending-and-Recieve-messages-to-a-Queue-tf3561376s2354.html#a9953620
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message