activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From westd <westdwe...@yahoo.co.uk>
Subject Re: Open port (1099) when using vm transport protocol
Date Wed, 11 Apr 2007 08:44:40 GMT

My broker is configured using Spring 2 as shown at the end of this message. 
I have 'useJmx=false' set but still the ports 1099 and a random port are
opened in the case of the vm protocol.  Is there something I'm missing?

Thanks.

	<amq:broker brokerName="broker" persistent="true" useShutdownHook="true"
deleteAllMessagesOnStartup="true" useJmx="false">
   
      <amq:memoryManager>  
           <amq:usageManager id="memory-manager" limit="5048576"/>
       </amq:memoryManager>
         
   		<amq:transportConnectors>
			<amq:transportConnector uri="vm://localhost"/>
		</amq:transportConnectors>
		
		<amq:persistenceAdapter>
			<amq:jdbcPersistenceAdapter>
				<property name="cleanupPeriod" value="60000"/>
				<property name="dataSource" ref="postgres-ds"/>
			</amq:jdbcPersistenceAdapter>
		</amq:persistenceAdapter>
	</amq:broker>


Christopher G. Stach II wrote:
> 
> westd wrote:
>> Hi,
>> 
>> I am trying to use the vm://localhost transport for an embedded active mq
>> broker.  The embedded broker listens on port 1099 and another random
>> port. 
>> When using tcp transport, these ports are not used.  I wouldn't mind too
>> much if these ports were only accessible on localhost, but they are
>> externally accessible and I am not allowed to open external ports on our
>> device.
>> 
>> Is there an option I can use to stop this?
>> 
>> Thanks
> 
> They are RMI ports.  Disable JMX.
> 
> -- 
> Christopher G. Stach II
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Open-port-%281099%29-when-using-vm-transport-protocol-tf3553820s2354.html#a9935423
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message