activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Jordan <brett.jor...@velsys.com>
Subject Re: embedded broker using Spring 2.0 broken!
Date Thu, 05 Apr 2007 03:06:58 GMT



Brett Jordan wrote:
> 
> 
>>> You tried the 4.1.1 release?
> 
> I hadn't, but I just tried it then and still get the error.
> I think there is a problem with the published xsd file. (I tried a few
> others from the same directory with no luck)
> In both the broker complex type , and the transportConnector complex type
> the last element in the sequence looks like this:
>       <xs:any namespace='##other'/> 
> 
> If I comment these 2 lines out (lines 474 and 4144), it parses and my
> embedded broker comes up. I will attach my edited version of the xsd file
> (taken from 
> http://http://people.apache.org/repository/org.apache.activemq/xsds/activemq-core-4.1-incubator-SNAPSHOT.xsd
> http://people.apache.org/repository/org.apache.activemq/xsds/activemq-core-4.1-incubator-SNAPSHOT.xsd
> . )
>   http://www.nabble.com/file/7641/activemq-core-4.1-incubator-SNAPSHOT.xsd
> activemq-core-4.1-incubator-SNAPSHOT.xsd 
> 
> I am new to xml schema, so I don't understand the intention of this
> element, or how to change my xml to conform.
> 
> 

It looks like this is caused by a bug in the XBean ant task that generates
the xsd.
The inclusion of the <xs:any namespace='##other'/> element in the sequence
for org.apache.activemq.broker.TransportConnector, forces that element to
have a child that conforms to it.
Like all other elements in that sequence it should have had minOccurs=0:

     <xs:any namespace='##other' minOccurs='0'/>

Can this be raised with XBean people ?
In the meantime, can someone possibly hand-edit the xsd file at 
http://people.apache.org/repository/org.apache.activemq/xsds/activemq-core-4.1-incubator-SNAPSHOT.xsd
http://people.apache.org/repository/org.apache.activemq/xsds/activemq-core-4.1-incubator-SNAPSHOT.xsd


I don't think anyone will be able to use the example for Spring 2.0 at 
http://activemq.apache.org/how-do-i-embed-a-broker-inside-a-connection.html
http://activemq.apache.org/how-do-i-embed-a-broker-inside-a-connection.html 
until this is addressed.
-- 
View this message in context: http://www.nabble.com/embedded-broker-using-Spring-2.0-broken%21-tf3509768s2354.html#a9849349
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message