activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mathulan <mathu...@gmail.com>
Subject Re: Stomp reconnect inconsistent
Date Fri, 16 Mar 2007 09:58:02 GMT

apache-activemq-4.1-20070315.010452-12.tar.gz (SNAPSHOT).

I did try with 4.2 as well.


James.Strachan wrote:
> 
> Which version are you using?
> 
> On 3/15/07, Mathulan <mathulan@gmail.com> wrote:
>>
>> Hi Folks,
>>
>> I am facing an inconsistent behavior when using Stomp client. The setup I
>> got here is.
>>
>> 1) Network set up is 2 Machines (Machine MA, Machine MB) connected over
>> LAN.
>> Each of these machines are running brokers BrkA on MA and BrkB on MB.
>> These
>> 2 brokers are TCP connected.  (On startup and Jconsole can see successful
>> connection and synchronized topics)
>> 2) There are 1 Publisher PubA, 1 Subscriber SubB. Both uses Stomp for
>> communicating with ActiveMQ
>> 3)  PubA attached to BrkA on MA and SubB attached to BrkB on MB. SubB is
>> on
>> Durable mode
>> 4) At the beginning if all goes well the publish/subscribe works well.
>> But
>> in the following scenario the SubB doesn't receive messages and needs a
>> restart. And after restart it continues to receive.
>>
>> Scenario:
>> 1) Failure: Lets say the SubB goes offline while there is no messages
>> left
>> on the topic (ie nothing pending to be delivered). And the comes back
>> online
>> again (no messages published while SubB is offline). Now PubA starts
>> publishing messages, SubB doen't receive any. And if you restart  SubB it
>> will receive the messages.
>> 2) Succes: Lets say there is no messages left and SubB goes offline, and
>> while SubB is offline PubA sends a message. When SubB comes back online
>> it
>> receives the offline message and continue to receive following messages.
>>
>> So in a nutshell if the Subscriber goes offline and there is no pending
>> messages in the topic we go a problem that we got to restart. After
>> Publisher sends a message. All other cases works fine.
>>
>> Can some one help to resolve this issue.
>>
>> Thank you,
>> Kind regards
>> Matt
>>
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Stomp-reconnect-inconsistent-tf3408084s2354.html#a9493618
>> Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> 
> James
> -------
> http://radio.weblogs.com/0112098/
> 
> 

-- 
View this message in context: http://www.nabble.com/Stomp-reconnect-inconsistent-tf3408084s2354.html#a9511568
Sent from the ActiveMQ - Dev mailing list archive at Nabble.com.


Mime
View raw message