activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Dillon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQ-1184) Allow activeio 3.1-SNAPSHOT to be compiled with JDK 1.4
Date Fri, 02 Mar 2007 04:09:02 GMT

    [ https://issues.apache.org/activemq/browse/AMQ-1184?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_38634
] 

Jason Dillon commented on AMQ-1184:
-----------------------------------

So... even though the build is fine, and _generating_ JDK 1.4 compatible classes... this codebase
is still _importing_ JDK 1.5 stuff, so its not buildable with JDK 1.4... nor is it _usable_
by JDK 1.4.

May need to retrotranslate activeio so that activemq 4.1 can use it... see AMQ-1185

> Allow activeio 3.1-SNAPSHOT to be compiled with JDK 1.4
> -------------------------------------------------------
>
>                 Key: AMQ-1184
>                 URL: https://issues.apache.org/activemq/browse/AMQ-1184
>             Project: ActiveMQ
>          Issue Type: Improvement
>            Reporter: Jason Dillon
>             Fix For: 4.1.1
>
>         Attachments: usejdk14.diff
>
>
> Use of one new-style for loop in activeio (and pom.xml config) is preventing activeio
3.1-SNAPSHOT from being used on JDK 1.4...

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message