activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Teemu Torma (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AMQCPP-81) openwire consumer never receives messages already in queue
Date Fri, 16 Mar 2007 15:03:35 GMT

    [ https://issues.apache.org/activemq/browse/AMQCPP-81?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_38851
] 

Teemu Torma commented on AMQCPP-81:
-----------------------------------

With trunk version, I now get exception if there is already a message in the queue.  This
happens when messagelistener is created and even before the connection is started (using client
acknowledge, but the message is never received by the callback).

AMQ Exception: OpenWireConnector::acknowledge - Message was not a commands::Message derivation.
  ../../../src/main/activemq/connector/openwire/OpenWireConnector.cpp:969
  ../../../src/main/activemq/connector/openwire/OpenWireConnector.cpp:1025
  ../../../src/main/activemq/core/ActiveMQConnection.cpp:228
[ERROR] AMQ Exception: OpenWireConnector::acknowledge - Message was not a comma\
nds::Message derivation.
  ../../../src/main/activemq/connector/openwire/OpenWireConnector.cpp:969
  ../../../src/main/activemq/connector/openwire/OpenWireConnector.cpp:1025
  ../../../src/main/activemq/core/ActiveMQConnection.cpp:228


> openwire consumer never receives messages already in queue
> ----------------------------------------------------------
>
>                 Key: AMQCPP-81
>                 URL: https://issues.apache.org/activemq/browse/AMQCPP-81
>             Project: ActiveMQ C++ Client
>          Issue Type: Bug
>          Components: Openwire
>    Affects Versions: 2.0
>            Reporter: Teemu Torma
>         Assigned To: Nathan Mittler
>             Fix For: 2.0
>
>         Attachments: test.cpp
>
>
> When starting an openwire consumer, it will never not receive messages already in queue.
 However, if a new message is sent to the queue, all previous and new messages are received.
> The attached program fails to receive the message the producer sends to the queue.  If
the consumer is created before sending the message, it is received just fine.
> The same problem can be reproduced with separate processes.  The problem does not appear
if using stomp.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message