activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bb aa <tracy...@yahoo.com.cn>
Subject Re: [test]I cannot run the Integration Tests
Date Mon, 19 Mar 2007 09:00:27 GMT
Another Question:
When I ran the unit tests of ActiveMQ by maven, I found that many modules, such as activemq-console
and activemq-web, have no test reported. Only activemq-core and activemq-jaas seems well.
Are there any test cases in those modules? Or is that my mistake?


bb aa <tracy4mq@yahoo.com.cn> : 

Hiram Chirino : On 3/16/07, bb aa  wrote:
> I have checked out ActiveMQ 4.1.0, and built it. Now I want to run the Integration Tests.
But I can't find some folders which the document mentioned. Such as :
> systest/itests/ejb
>
> And, when I run this command :
> cd activemq-ra
> mvn rar:install-snapshot

try runnin just:
mvn install


> The output is :
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Required goal not found: rar:install-snapshot
> [INFO] ------------------------------------------------------------------------
>
> Could Someone tell me what's wrong please?
>
>
>


-- 
Regards,
Hiram

Blog: http://hiramchirino.com

Thanks!
It works.
But I still can't find 

systest/itests/

Where it should reside?


   
 

 		
---------------------------------
 Mp3疯狂搜-新歌热歌高速下   
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message