activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "james strachan (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AMQ-862) POM error means I can't use a dependency on 4.1-incubator-SNAPSHOT
Date Wed, 07 Mar 2007 14:19:21 GMT

     [ https://issues.apache.org/activemq/browse/AMQ-862?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

james strachan resolved AMQ-862.
--------------------------------

    Resolution: Fixed

I'm guessing this is now fixed as you can just use the 4.1.0 release (or 4.1.1 release thats
about to go out). If not, do let us know exactly what is required to hack the poms and we
can do it

> POM error means I can't use a dependency on 4.1-incubator-SNAPSHOT
> ------------------------------------------------------------------
>
>                 Key: AMQ-862
>                 URL: https://issues.apache.org/activemq/browse/AMQ-862
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 4.1.0
>            Reporter: Aaron Mulder
>            Priority: Critical
>
> I'm trying to build jencks, which has a dependency on ActiveMQ 4.1-incubator-SNAPSHOT.
 I get the following unresolved dependencies:
> org.apache.activemq:activemq-core:jar:4.1-incubator-SNAPSHOT
> org.apache.activemq:activemq-core:test-jar:tests:4.1-incubator-SNAPSHOT
> What it's actually trying to download is:
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/activemq/activemq-core/4.1-incubator-SNAPSHOT/activemq-core-4.1-incubator-20060801.170356-6.jar
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/activemq/activemq-core/4.1-incubator-SNAPSHOT/activemq-core-4.1-incubator-20060801.170356-2-tests.jar
> Those are invalid versions.  When I asked about this on the maven IRC, I was told:
> the problem is here: http://people.apache.org/repo/m2-snapshot-repository/org/apache/activemq/activemq-parent/4.1-incubator-SNAPSHOT/activemq-parent-4.1-incubator-20060804.071007-16.pom
> In the dependencyManagement they're using, they have expressions for the versions.  Those
resolve to the current POM's (the one specifying the dependencies) version, instead of resolving
them as snapshots.  It's a common problem when using that expression for shortcuts.
> It would be great if this could be fixed so that I could build jencks.  Thanks!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message