activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Dillon (JIRA)" <j...@apache.org>
Subject [jira] Created: (AMQ-1185) ActiveMQ 4.1 has crept in some Java 5 APIs, which prevent it from being used on Java 1.4 JVMs
Date Thu, 01 Mar 2007 22:48:02 GMT
ActiveMQ 4.1 has crept in some Java 5 APIs, which prevent it from being used on Java 1.4 JVMs
---------------------------------------------------------------------------------------------

                 Key: AMQ-1185
                 URL: https://issues.apache.org/activemq/browse/AMQ-1185
             Project: ActiveMQ
          Issue Type: Bug
    Affects Versions: 4.1.1
            Reporter: Jason Dillon
            Priority: Blocker


A few bits of Java 5 API has made it into the AMQ 4.1 branch, which prevent 4.1 from being
used on Java 1.4 JVMS.

Apache Geronimo v1.2 needs AMQ 4.1 running on Java 1.4.

So far I don't see anything major which prevents AMQ 4.1 from being compiled with Java 1.4...
only a few minor changes to keep compatibility.  The alternative is of course to use the retrotranslator-maven-plugin
to generate 1.4 compatible jars for each module (the new retrotranslator:translate-project
makes this very easy to use, includes attaching jdk14 artifacts).

But IMO, that would just add more complexity for AMQ 4.1 when only a few simple changes will
allow the it to be native 1.4... though you folks might consider using retrotranslator:translate-project
for trunk to create 1.4 compatible jars for the new AMQ (> 4.1.x) bits.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message