activemq-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "james strachan (JIRA)" <>
Subject [jira] Resolved: (AMQ-1018) Tomcat JVM hangs when it tried to get ConnectionFactory object
Date Wed, 07 Mar 2007 15:40:21 GMT


james strachan resolved AMQ-1018.

    Resolution: Cannot Reproduce

I don't really understand what "3 iterations of start and stop works successfully"  and I
can't reproduce your issue.

FWIW the stack trace appears to be taht tomcat has blocked trying to load classes into the
ClassLoader; which is really a Tomcat issue rather than ActiveMQ.

> Tomcat JVM hangs when it tried to get ConnectionFactory object
> --------------------------------------------------------------
>                 Key: AMQ-1018
>                 URL:
>             Project: ActiveMQ
>          Issue Type: Bug
>    Affects Versions: 4.0.1
>         Environment: Tomcat 5.5.9, Activemq 4.0.1
>            Reporter: Suvarna Raju Madhey
>            Priority: Critical
>             Fix For: 4.0.3
>         Attachments: StackTrace
> I have deployed my application in Tomcat 5.5.9, which uses Activemq 4.0.1. 
> To get ConnectionFactory I have written a method called getConnectionFactory.
> Following way i am tring to lookup..
> Context ctx = new InitialContext();
> Context ctx2= (Context) initCtx.lookup("java:comp/env");
> ConnectionFactory cf = (ConnectionFactory) ctx2.lookup("jms/ConnectionFactory");
> 3 iterations of start and stop works successfully. But when I start the application 4th
time, it executes Context ctx2 = (Context)initCtx.lookup("java:comp/env"); then it goes to
next line. After that it never returns ConnectionFactory. After I notice that the application
> Please find the stack which i got by running "kill -3 <tomcat-process-pid>

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message